MacOS切换Flutter SDK版本号


发文时间:2019年02月02日 14:36:08     编辑:Aaron      标签:一些flutter常用的知识点 502


MacOS切换flutter版本号,便于各个版本的调试。

One:Flutter官网可下载不同版本的SDK

  https://docs.flutter.dev/development/tools/sdk/releases?tab=macos#macos

  将下载好的SDK放入本地合适的位置,不要重名即可,命名最好带上当前的版本号等,便于切换。

image.png

Two:配置flutter的环境变量

打开终端输入 open ~/.bash_profile   目的是为了打开bash_profile 文件

open ~/.bash_profile

image.png

#flutter  切换你需要的flutter SDK版本,不需要的话#注释即可
#export PATH=$PATH:~/opt/flutter_sdk/2.0/bin
#alias flutter1='~/opt/flutter_sdk/1.22.6/bin/flutter'

export PATH=$PATH:~/opt/flutter_sdk/1.22.6/bin
alias flutter1='~/opt/flutter_sdk/2.0/bin/flutter'

  编辑好后保存bash_profile文件,后而在终端执行 source ~/.bash_profile 让配置生效。

source ~/.bash_profile

image.png

  可以通过 flutter doctor 检查当前flutter SDK版本号,是否跟你所编辑的一致。

 flutter doctor

  如bash_profile文件截图所示,我当前设置的是1.22.6的版本号,在flutter doctor中一致,证明更换版本号成功。(若更换未成功可多运行几次 source ~/.bash_profile,或重启电脑)

image.png

Three:完善IDE中的SDK版本和项目工程

 我目前使用的是as (Android Studio),打开设置 如下图所示

image.png

image.png

然后找到工程中的pubspec.yaml 的flutter pub get 重拉一下库,若有报错则在终端执行下flutter clean 待清理成功后,重拉flutter pub get 即可。

image.png


    

                                         What do you want in life?

 

若无特殊说明,此文章为博主原创。
写稿不易,如需转载,请注明出处: https://www.aaroner.cn/art/21.html




SITE MAP

  FOLLOW US